Sign In to join the community | Help
Lawn & Garden

40 v lawn mower won't start but the light comes on the battery is fully charged.

Hello all!

I have the 40V Ryobi 20-inch lawn mower. I was out mowing today and all of a sudden, the mower turned off and wouldn't turn back on. The lights stayed on, but it would not restart. The battery showed one bar left, but just in case, I switched over to the fully charged back up. Still nothing. I flipped the mower over and there was a little grass in the underside, but not enough to block anything. I still cleaned it out and could manually rotate the blade freely. I also pulled out the battery and fuse key and made sure all connections were free of debris. Still the lights came on but the mower wouldn't start. I thought maybe it got too hot and let it sit. Everything is cool to the touch and still, the same issue.

Does anyone have any ideas? I've only had this mower for maybe 2.5-3 months. It likes to turn off randomly while mowing but has always come back on before...

Thanks in advance!
Not what you were looking for ? Try posting a question
Posted 2017-07-12T22:49:13+0000  by laforge32 laforge32
 
Hey laforge32.

Have you tried contacting Ryobi Outdoor Products for help troubleshooting this?

Their phone number is 1800 860 4050 or click on the orange link above. Hit me back up here so I know that you have been taken care of.

Posted 2017-07-13T11:13:18+0000  by Ingar_HD_ATL
 
Not what you were looking for ? Try posting a question

Topic
Categories+